0 votes
1 view
in Azure by (5.8k points)

I've been experimenting a bit with the AzureML package. It seems works fine unless there is a need for external libraries.

Consider the following code (the function fun usually does quite a bit more):

fun<- function (b5) {

    res <- require(rmarkdown)

    res

}

test <- as.data.frame(

    cbind(

        c(0.0,  0.3,  0.0,  0.0,  0.0),

        c(0.0,  0.0,  0.0, -0.4,  0.0),

        c(0,      0,    0,    0,    0))

)

api <- publishWebService (

  ws,

  fun = fun,

  name = "Talection-fun",

  inputSchema = test,

  packages = c("talection","psych","jsonlite","rmarkdown","knitr")

)

The service returns FALSE

Created new folder: /var/folders/zf/587__ss15z7_tq240vtpb68c0000gn/T//Rtmpyu2qRC/dir138e46cbc778f/packages/bin/windows/contrib/3.1

Request failed with status 401. Waiting 9.7 seconds before retry

..........    ans

1 FALSE

Sourced file '/Users/roffe/Documents/talections/code/Web Services/WebServices.R'

It seems that knitrpsych, and jsonlite work OK, whereas markdown and talection (all of which are binary packages in a miniCRAN repository) apparently are located and uploaded, but not installed. Because there's an error message if I remove them from the miniCRAN repository.

Is there a way to trace what happens to the libraries? Or anything else I can do to make this work? 

1 Answer

0 votes
by (9.5k points)

The problem is with miniCRAN package. miniCRAN is responsible for uploading and installing packages to Azure.

See this for more details: https://github.com/RevolutionAnalytics/AzureML#installation-instructions

Welcome to Intellipaat Community. Get your technical queries answered by top developers !


Categories

...