0 votes
1 view
in Azure by (3.8k points)

To generate builds to testers we use VSTS in our project. When we check out and run the branch in our mac with xcode, it works fine. But when I try to release a build through VSTS it throws an error as below and the build fails.

ld: could not reparse object file in bitcode bundle: 'Invalid bitcode version (Producer: '902.0.39.2_0' Reader: '900.0.39.2_0')', using libLTO version 'LLVM version 9.0.0, (clang-900.0.39.2)' for architecture arm64

I understand that the issue might be because of the fact that there are two different versions of the compiler hanging around. I am using Xcode 9.2 and the server which builds the source code to upload also has Xcode 9.2. One more thing is, in past i have made a commit with beta Xcode version 9.4 to the branch. Can that create an issue or is it something else that i am missing here.

Also i hear from some stack-overflow and git suggestions that updating Xcode will fix the issue. I am fine with that but want to have that option as last because there are some servers and builds queued in the server like android and WebApp build which we have automated through VSTS which will be stopped momentarily.

1 Answer

0 votes
by (8k points)

Enable the Bitcode to No in Build settings.

You can also downgrade the binary framework to an older version.

...