0 votes
1 view
in Devops and Agile by (23.6k points)

I am using git on Windows. I installed the msysgit package. My test repository has a self-signed certificate at the server. I can access and use the repository using http without problems. Moving to https gives the error "SSL Certificate problem: unable to get local issuer certificate".

I have the self-signed certificate installed in the Trusted Root Certification Authorities of my Windows 7 - client machine. I can browse to the https repository url in Internet Explorer with no error messages

I verified that git was still working by cloning a GitHub Repository via https.

The only thing I see that's different to the blog post is that my certificate IS the root - there is no chain to reach it. My certificate originally came from clicking the IIS8 IIS Manager link 'Create Self Signed Certificate'. Maybe that makes a certificate different in some way to what curl expects.

How can I get git/curl to accept the self-signed certificate?

1 Answer

0 votes
by (40.4k points)

For this question, 

If you want to disable the SSL verification completely use:

git config --global http.sslVerify false

Note: This command may open you to attacks. Therefore turn on verification again as soon as possible:

For enabling SSL verification use:

git config --global http.sslVerify true

...