Explore Courses Blog Tutorials Interview Questions
0 votes
in Data Science by (18.4k points)

I have installed Anaconda on windows10 64-bit version but when I launched it is giving me the message:

Microsoft Windows [Version 10.0.14393] (c) 2016 Microsoft Corporation. All rights reserved.

C:\Users\Carlos>jupyter notebook Traceback (most recent call last):

File "C:\Program Files\Anaconda3\Scripts\", line 3, in import notebook.notebookapp

File "C:\Program Files\Anaconda3\lib\site-packages\notebook\", l ine 32, in from zmq.eventloop import ioloop

File "C:\Program Files\Anaconda3\lib\site-packages\", line 34, in from zmq import backend

File "C:\Program Files\Anaconda3\lib\site-packages\zmq\", l ine 40, in reraise(*exc_info)

File "C:\Program Files\Anaconda3\lib\site-packages\zmq\utils\", lin e 34, in reraise raise value

File "C:\Program Files\Anaconda3\lib\site-packages\zmq\", l ine 27, in _ns = select_backend(first)

File "C:\Program Files\Anaconda3\lib\site-packages\zmq\backend\", lin e 26, in select_backend mod = import(name, fromlist=public_api)

File "C:\Program Files\Anaconda3\lib\site-packages\zmq\backend\cython__init__ .py", line 6, in from . import (constants, error, message, context,

ImportError: DLL load failed: The specified module could not be found.

I tried to uninstall and installed it again but still, I am getting the same error. 

1 Answer

0 votes
by (36.8k points)

As per my knowledge, you have an issue with installing this is caused by the pyzmq package. So you can do this:

conda uninstall pyzmq 

conda install pyzmq 

conda install jupyter 

Now you can open Jupyter Notebook

If you are a beginner and want to know more about Data Science the do check out the Data Science course

Related questions

Welcome to Intellipaat Community. Get your technical queries answered by top developers!

29.3k questions

30.6k answers


104k users

Browse Categories