Back

Explore Courses Blog Tutorials Interview Questions
0 votes
1 view
in Big Data Hadoop & Spark by (11.4k points)
I already installed Hadoop on my machine "Ubuntu 13.05" and now I have an error when browsing localhost:50070 the browser says that the page does not exist.

2 Answers

0 votes
by (32.3k points)
edited by

After release of Hadoop 3.0.0 Alpha 1, the port 50070 was changed to 9870 for 3.0.0-alpha1

I.e. http://localhost:9870

Also, lots of other ports are changed:

Namenode ports: 50470 --> 9871, 50070 --> 9870, 8020 --> 9820

Secondary NN ports: 50091 --> 9869, 50090 --> 9868

Datanode ports: 50020 --> 9867, 50010 --> 9866, 50475 --> 9865, 50075 --> 9864



 

If you are running Hadoop 2._._ , you can try this approach:

  • bin/stop-all.sh

  • bin/hdfs namenode -format

  • # sudo service hadoop-hdfs-namenode start ;

# sudo service hadoop-hdfs-datanode start ;

# sudo service hadoop-hdfs-secondarynamenode start ;

Now, type jps and see if namenode and data node are running.

Then to verify services have started, you can check the web console http://hadoop:50070/

Hopefully, you will see that your localhost:50070 is working.

If you are a beginner in Hadoop, do check out this awesome video tutorial:

0 votes
by (108k points)

There are 2 cases feasible:

1. If you are running Hadoop version 3.0.0 then let me tell you that there was a change of configuration and http://localhost:50070 was moved to http://localhost:9870

2. If you are running Hadoop version 2.X, then what you can do is just stop all the daemon services, change the name node and again restart the services.

Following are the steps:

 bin/stop-all.sh

 bin/hadoop namenode -format

 bin/start-all.sh

I hope, this will resolve your issue.

Browse Categories

...