Explore Courses Blog Tutorials Interview Questions
0 votes
in Azure by (45.3k points)

I'm trying to configure TeamCity to build the project located on the Visual Studio Team Services with Git as VCS. The project contains spaces in the URL, so it looks like:

Clone from Visual Studio 2013 works fine, from command line too. When I'm configuring VCS Root in TeamCity and press the Test Connection button it says that connection established, but when I'm trying to run the build TeamCityt reports that there is no compatible agents, and on the Compatible Agents tab of the build I see the message: Implicit requirements: 20project defined in VCS Root: Git VS MySrv

Is it possible to fix this issue?

P.S. I tried to rename repository on VS Team Services, but it adds to the Url collection name with the spaces :(

1 Answer

0 votes
by (16.8k points)

Do you still get this behaviour, if you try to use unescaped url (without %20 replacing space)?

Another option is to escape '%' sign itself with another '%' - so escaped url of your repository will look like this

Browse Categories