0 votes
1 view
in Devops and Agile by (16.9k points)

Note: while the use-case described is about using submodules within a project, the same applies to a normal git clone of a repository over HTTP.

I have a project under Git control. I'd like to add a submodule:

git submodule add http://github.com/jscruggs/metric_fu.git vendor/plugins/metric_fu

But I get

...

got 1b0313f016d98e556396c91d08127c59722762d0

got 4c42d44a9221209293e5f3eb7e662a1571b09421

got b0d6414e3ca5c2fb4b95b7712c7edbf7d2becac7

error: Unable to find abc07fcf79aebed56497e3894c6c3c06046f913a under http://github.com/jscruggs/metri...

Cannot obtain needed commit abc07fcf79aebed56497e3894c6c3c06046f913a

while processing commit ee576543b3a0820cc966cc10cc41e6ffb3415658.

fatal: Fetch failed.

Clone of 'http://github.com/jscruggs/metric_fu.git' into submodule path 'vendor/plugins/metric_fu'

I have my HTTP_PROXY set up:

c:\project> echo %HTTP_PROXY%

http://proxy.mycompany:80

I even have a global Git setting for the HTTP proxy:

c:\project> git config --get http.proxyhttp://proxy.mycompany:80

Has anybody gotten HTTP fetches to consistently work through a proxy? What's really strange is that a few projects on GitHub work fine (awesome_nested_set for example), but others consistently fail (rails for example).

1 Answer

0 votes
by (22.3k points)

With the help of following command first you need to set the HTTP proxy that Git uses in global configuration property http.proxy:

$ git config --global http.proxy http://proxy.mycompany:80

Then authenticate the same with the proxy:

$ git config --global http.proxy http://mydomain\\myusername:[email protected]:8080

...