0 votes
1 view
in RPA by (12.8k points)

In the Rest Webservice Command, I don't see any option to pass a variable in the URI.

We do not want to hard the endpoint in the script.

As an e.g I will want the script to use different points for dev/stage and prod.

Is there a workaround for this.

On building a URI with variables like https://$v_hostname$/test-rs-v1/employee/data send request works fine but bot runs we get an error stating :

The hostname could not be parsed.

1 Answer

0 votes
by (29.8k points)

The following fix works on version 11.3.1 or above

Make sure that $v_hostname$ contains a value at the run time, using debugging option or message box command.
If the hostname/URL is invalid you will get "The remote name could not be resolved:".

Welcome to Intellipaat Community. Get your technical queries answered by top developers !


Categories

...