0 votes
1 view
in Java by (2.6k points)

I'm trying to configure my e-mail on Jenkins/Hudson, and I constantly receive the error:

java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be

    non-empty

I've seen a good amount of information online about the error, but I have not gotten any to work. I'm using Sun's JDK on Fedora Linux (not OpenJDK).

Here are a few things I've tried. I tried following the advice from this post, but copying the certs from Windows over to my Fedora box hosting Jenkins didn't work. I tried following this guide as I'm trying to configure Gmail as my SMTP server, but it didn't work either. I also tried to download and move those cacert files manually and move them over to my Java folder using a variation of the commands on this guide.

I am open to any suggestions as I'm currently stuck right now. I have gotten it to work from a Windows Hudson server, but I am struggling with Linux.

1 Answer

0 votes
by (101k points)

I have tried the following and this fixed the problem for me on Ubuntu:

sudo /var/lib/dpkg/info/ca-certificates-java.postinst configure

ca-certificates-java is not a dependency in the Oracle JDK/JRE (Java Runtime Environment). So, this must be explicitly installed.

If you want to learn Java from the top experts, you can take up this Java Course program by Intellipaat.

Welcome to Intellipaat Community. Get your technical queries answered by top developers !


Categories

...