Back

Explore Courses Blog Tutorials Interview Questions
0 votes
1 view
in BI by (17.6k points)

I'm using Tableau 9.0.2 to generate graphs and I can't for the life of me figure out how to move (ideally drag, right?) the field name for my x-axis from the top to the bottom of the graph, by the units, where it should be.

I'm attaching a picture because it's probably the easiest way to make clear what I'm trying to do, given this is a question of positioning:

Tableau graph with field name "Iterations" at top of graph, not bottom

This Tableau graph has the field name "Iterations" at the top of the graph, not the bottom, where it should be. While this might not seem like a huge concern, it means that these graphs are not immediately exportable.

How can I move the label "Iterations" to the bottom of the graph, next to its axis?

The answer currently offered below allows for manual image modification within Tableau, which is unsatisfactory. It seems bizarre to me that the default, unchangeable behavior of Tableau goes against standard practice in graphing (labels next to labeled).

1 Answer

0 votes
by (47.2k points)
  • If your target is just to get the headers and the axis label in the same place, one alternative would be to move the headers to the top of the chart as opposed to moving the axis label to the bottom.

  • Now, Go to Analysis/Table Layout/Advanced... and uncheck the option "Show innermost level at bottom of view when there is a vertical axis". This will move your Iterations headers to the top of the chart, and now everything will be in the same place.

  • If that's not an acceptable alternative for you, here's the only (kind of unfortunate) solution I can think of:

  • Place your worksheet in a dashboard.

  • Then, Right-click on the axis label and select Hide Field Labels for Columns.

  • Create a text box with your desired axis label (in this case "Iterations") and place it below the chart. Your headers and your DIY, home-brewed, hacktastic axis label will now both be at the bottom.

  • Your problem is the [Iterations] dimension in Tableau is a Discrete type. Tableau always puts discrete labels at the top. The easiest solution for this is to change the [Iterations] dimension to a continuous data type. Now, that will put the axis label on the bottom. You may need to play with the number format to avoid false interpolation of decimals.

Firstly register yourself in an industry-recognized Tableau Desktop Certification such as you can register for our Tableau Training online. 

Related questions

0 votes
1 answer
asked Jul 24, 2019 in BI by Vaibhav Ameta (17.6k points)
0 votes
1 answer
asked Jul 16, 2019 in Python by leealex956 (7.3k points)
0 votes
1 answer
asked Oct 16, 2020 in BI by Sudhir_1997 (55.5k points)
+2 votes
3 answers
Welcome to Intellipaat Community. Get your technical queries answered by top developers!

28.4k questions

29.7k answers

500 comments

94k users

Browse Categories

...