Back

Explore Courses Blog Tutorials Interview Questions
0 votes
1 view
in AWS by (19.1k points)

I'm following Github's instructions for adding an SSH key. I've generated the id_rsa.pub file from my AWS EC2 instance, but I cannot complete the step that has me copy the contents of the file using xclip because I cannot install xclip onto the EC2 instance.

  1. I tried to install xclip on the EC2 instance using sudo yum install xclip, but that didn't work ("No package xclip available").
  2. So I looked around and found more detailed install instructions, but they didn't work either ("curl: (22) The requested URL returned error: 404 Not Found"), and the suggested correct URLs in the comments also failed.
  3. (I also tried just copying the text contents of the id_rsa.pub file using Putty and ctl-c, but Github declared the resulting key invalid.)

So, how do I install xclip on 64-bit Amazon Linux AMI 2012.09?

1 Answer

0 votes
by (44.3k points)

You can just SSH into the EC2 instance and then use the cat command to get the key to your terminal. Then copy and use it wherever you want, there is no need for xclip.

Related questions

0 votes
1 answer
asked Jul 12, 2019 in AWS by yuvraj (19.1k points)

Want to get 50% Hike on your Salary?

Learn how we helped 50,000+ professionals like you !

Browse Categories

...