0 votes
1 view
in AWS by (19.2k points)

I'm working to set up Panda on an Amazon EC2 instance. I set up my account and tools last night and had no problem using SSH to interact with my own personal instance, but right now I'm not being allowed permission into Panda's EC2 instance.

I'm getting the following error:

@         WARNING: UNPROTECTED PRIVATE KEY FILE!         @

Permissions 0644 for '~/.ec2/id_rsa-gsg-keypair' are too open.

It is recommended that your private key files are NOT accessible by others.

This private key will be ignored.

I've chmoded my keypair to 600 in order to get into my personal instance last night, and experimented at length setting the permissions to 0 and even generating new key strings, but nothing seems to be working.

Any help at all would be a great help!

 

1 Answer

0 votes
by (44.6k points)

Basically, key pair files have to secure like passwords to avoid misuse. So, ssh client would require it to be secure.

Set your directory to 700, and this will solve the issue

chmod 700 ~/.ec2 

Or set chmod your file

chmod 700 yourkey.pem

Welcome to Intellipaat Community. Get your technical queries answered by top developers !


Categories

...