0 votes
1 view
in AWS by (19.2k points)

I'm attempting to copy my MySQL database from an Amazon EC2 to an RDS:

I successfully did a mysqldump of my database into my root folder using this:

[email protected]:~# mysqldump my_database -u my_username -p > my_database.sql

Then I tried to transfer this .sql file to my new RDS database:

[email protected]:~# mysql my_database -u my_username -p -h  

my_new_database.xxxxxxxxx.us-east-1.rds.amazonaws.com < my_database.sql

Unfortunately, I get the following error message:

You do not have the SUPER privilege and binary logging is enabled 

(you *might* want to use  the less safe log_bin_trust_function_creators variable)

I tried to GRANT SUPER.. in a variety of ways but I'm getting errors when I try to do that too. Typing mysql > FLUSH privileges; doesn't work either.

I'm a MySQL beginner so sorry for such an easy question. Thoughts?

1 Answer

0 votes
by (44.6k points)

you would have to set log_bin_trust_function_creators to 1 in AWS console, to load your dump file without errors.

To load your dump file without any errors, set log_bin_trust_function_creators to 1 in AWS console

You can also ignore the errors by using the -f option to load the rest of the dump file

mysql -f my_database -u my_username -p -h  

my_new_db.xxxxxxxxx.us-east-1.rds.amazonaws.com < my_database.sql

Even if there are errors, -f will report it and will continue processing the rest of the dump file

Welcome to Intellipaat Community. Get your technical queries answered by top developers !


Categories

...