0 votes
1 view
in RPA by (11.8k points)

So I have a combobox for the user to select whether he is an old customer or a new customer. With my process, I was able to identify the combobox as an AA element so my process is now able to identify the combobox and click on it when it runs. But the problem starts when I need to select the "new customer" option after opening the combobox. I am unable to identify the option either as an HTML element nor an AA element. Because of this, the process is not able to select an option and throws an error.

What I tried:

I tried an alternative where I added a navigate stage for just the dropdown/combobox and in the properties for this stage I added "select item" as the action and entered the name for the option which in this case is "new customer" along with the item position. This does not work either and throws an error saying "select item" cannot be used for AA whose role is "static text".

P.S: I checked the attributes for the combobox and unchecked the role attribute but that did not work.

1 Answer

0 votes
by (27.7k points)
What you can try to do is use  ComboBox as standard HTML Combo Box(Element Type) in Application Modeller. But in the Navigation step use Select Item as Action and in Inputs section use Item Position as a Number.
Where 0 is the first position in Combobox, blank. 1 is the first position, in your case, it would be "new customer" and 2 would be "old customer".

I think this'll work!

Related questions

Welcome to Intellipaat Community. Get your technical queries answered by top developers !


Categories

...