0 votes
1 view
in Azure by (32.3k points)

I am setting local host port in local.setting.json. Referring Microsoft doc https://docs.microsoft.com/en-us/azure/azure-functions/functions-run-local

The file looks like below:

{

  "IsEncrypted": false,

  "Values": {

    "AzureWebJobsStorage": "",

    "AzureWebJobsDashboard": ""   

  },

  "Host": {

    "LocalHttpPort": 7073

  }

}

When I run/debug the solution, VS still host the app on the default port (7071)

I have checked the bin directory, the local.setting.json the file is geting there with above settings. Running Azure Function CLI (func host start) from bin directory correctly read the port number.

Looks like VS is not using the "LocalHttpPort" port. Is there any other changes required in the settings. I have Visual Studio 2017 Preview (2)

1 Answer

0 votes
by (16.8k points)

With CLI version 1.2.1, and go with the following Application arguments setting in Project Properties -> Debug might work for you. 

host start --port 7074 --nodeDebugPort 5860

Welcome to Intellipaat Community. Get your technical queries answered by top developers !


Categories

...