0 votes
1 view
in Blockchain by (7k points)

I am trying to install my custom chain code in my local Hyperledger Fabric v1.0 environment.

For this I have followed the documentation build your first network and I am using first network sample with in the github project. No it is up and running with ./byfn.sh -m up and executing all the scripts for channel creating, chain code installation and instantiation and all by running script.sh file.

Now I have changed the following to tryout my custom chaincode

peer chaincode install -n mycc -v 1.0 -p github.com/hyperledger/fabric/examples/chaincode/go/chaincode_example02>&log.txt

This I have changed to

peer chaincode install -n mycc -v 1.0 -p github.com/myuserId/fabrcicV1_chaincodes/mychaincode >&log.txt

Now by running ./byfn.sh -m up getting the exception

2017-08-22 11:01:17.048 UTC [msp] GetDefaultSigningIdentity -> DEBU 002 Obtaining default signing identity
2017-08-22 11:01:17.048 UTC [chaincodeCmd] checkChaincodeCmdParams -> INFO 003 Using default escc
2017-08-22 11:01:17.048 UTC [chaincodeCmd] checkChaincodeCmdParams -> INFO 004 Using default vscc
Error: Error getting chaincode code chaincode: path to chaincode does not exist: github.com/myuserId/fabrcicV1_chaincodes/mychaincode
Usage:
  peer chaincode install [flags]
Flags:
  -c, --ctor string      Constructor message for the chaincode in JSON format (default "{}")
  -l, --lang string      Language the chaincode is written in (default "golang")
  -n, --name string      Name of the chaincode
  -p, --path string      Path to chaincode
  -v, --version string   Version of the chaincode specified in install/instantiate/upgrade commands
Global Flags:
      --cafile string              Path to file containing PEM-encoded trusted certificate(s) for the ordering endpoi
      --logging-level string       Default logging level and overrides, see core.yaml for full syntax
  -o, --orderer string             Ordering service endpoint
      --test.coverprofile string   Done (default "coverage.cov")
      --tls                        Use TLS when communicating with the orderer endpoint
!!!!!!!!!!!!!!! Chaincode installation on remote peer PEER0 has Failed !!!!!!!!!!!!!!!!
========= ERROR !!! FAILED to execute End-2-End Scenario ===========

I have the repository there in github, then why it is not showing does not exit?

I have cloned the same to Windows 7 machine under the path $GOPATH/src/github.com/ and given local path, then also I am getting the same error. I am running all the commands through docker quick start terminal for windows 7.

Please suggest where I am doing wrong.

Also in some of the network log I have found a location /opt/gopath/src/github.com/.... and where it is pointing to. In my windows path gopath is /c/users/public/fabricv1.

Since I am not much familiar with the tool, please comment on this also.

After doing some analysis from my side, it seems like the chain code is reading from some pre-mounted directories sacc/, fabcar/, /marble02 , chaincode_example_02, hyperledger/ under the path  [email protected]:/opt/gopath/src/chaincodedev/chaincode# and chaincode also pre-loaded at the time of making the network up using docker image. There it seems no effect by adding chaincode in windows folder and it is from the above said virtual machine path.

So what can I do now to continue my work? is there any way to install my custom chaincode to the local network. I tried with my githhub path and local path but no use. please somebody help :(

1 Answer

0 votes
by (14.5k points)

You are facing the issue because your chaincode is not present in your $GOPATH. You should try this: 

go get github.com/myuserId/fabrcicV1_chaincodes/mychaincode

Before installing the chaincode on peers, make sure that your chain code resides inside fabric-samples/chaincode folder. 

Make sure to mount an additional folder within $GOPATH of the CLI container:

- ./../chaincode/:/opt/gopath/src/github.com/hyperledger/fabric/examples/chaincode/go

Welcome to Intellipaat Community. Get your technical queries answered by top developers !


Categories

...