Back

Explore Courses Blog Tutorials Interview Questions
0 votes
1 view
in Blockchain by (4.1k points)

Because I want to install a new clear version of Hyperledger Fabric, I deleted old Hyperledger file of one month ago, and run "vagrant destroy".

I run "vagrant up", and "vagrant ssh" successfully.

I "make peer" successfully, when I run "peer", if failed. When I run "make peer" and "peer" again, the error is pop up as below:

[email protected]:/opt/gopath/src/github.com/hyperledger/fabric$ make peer
make: Nothing to be done for `peer'.
[email protected]:/opt/gopath/src/github.com/hyperledger/fabric$ peer
No command 'peer' found, did you mean:
 Command 'pee' from package 'moreutils' (universe)
 Command 'beer' from package 'gerstensaft' (universe)
 Command 'peel' from package 'ears' (universe)
 Command 'pear' from package 'php-pear' (main)
peer: command not found
[email protected]:/opt/gopath/src/github.com/hyperledger/fabric$
[email protected]:/opt/gopath/src/github.com/hyperledger/fabric$ cd peer
[email protected]:/opt/gopath/src/github.com/hyperledger/fabric/peer$ ls -l
total 60
drwxr-xr-x 1 vagrant vagrant   204 Jun 26 01:16 bin
-rw-r--r-- 1 vagrant vagrant 17342 Jun 25 14:18 core.yaml
-rw-r--r-- 1 vagrant vagrant 35971 Jun 25 14:18 main.go
-rw-r--r-- 1 vagrant vagrant  1137 Jun 23 08:46 main_test.go

1 Answer

0 votes
by (14.4k points)

Note: 

The file location for the binary peer is:

"./build/bin/folder" 

And, for your configuration the full path is"

"/opt/gopath/src/github.com/hyperledger/fabric/build/bin/"

Fix this path configuration and your issue will be resolved. 

Welcome to Intellipaat Community. Get your technical queries answered by top developers!

28.4k questions

29.7k answers

500 comments

94.2k users

Browse Categories

...