Back

Explore Courses Blog Tutorials Interview Questions
0 votes
1 view
in SQL by (20.3k points)

I got the Error Code: 2013. Lost connection to MySQL server during query error when I tried to add an index to a table using MySQL Workbench. I noticed also that it appears whenever I run a long query.

Is there a way to increase the timeout value?

1 Answer

0 votes
by (40.4k points)

In the new version of MySQL WorkBench, you can change the specific timeouts.

For you, if it is under Edit → Preferences → SQL Editor → DBMS connection read time out (in seconds): 600

Then the value will be changed to 6000.

Also, uncheck the limit rows. If you are putting the limit every time then it will be difficult for you to search the whole data set.

Learn SQL with the help of this SQL Tutorial.

Enroll yourself in the best sql courses to learn in-depth about SQL statements, queries and become proficient in SQL.

Related questions

Browse Categories

...