0 votes
1 view
in AWS by (19.2k points)

The site works perfectly fine on HTTP, however, does not work on HTTPS. I've followed all the steps on this page to create a self-signed certificate and add it to my Elastic Beanstalk environment. http://docs.aws.amazon.com/elasticbeanstalk/latest/dg/configuring-https.html

I'm also getting a successful certificate response back from IAM using the following command: 

aws iam get-server-certificate --server-certificate-name

After updating Elastic Beanstalk with the certificate, I've also added add a rule to the security group that allows inbound traffic from 0.0.0.0/0 to port 443. Finally, I've also validated that my load-balancer listener has HTTPS set up correctly.

In spite of all that, my calls to https are not resolving, while HTTP is working perfectly fine. Any other thoughts on this? Any help would be much appreciated.

Please let me know if you need any more information. Desperately looking for some insight/help into this.

Anyway, not being able to resolve this issue with my site/code, I tried to set up HTTPS on the sample site provided on Elastic Beanstalk. Interestingly enough, even that is not working.

1 Answer

0 votes
by (44.6k points)

You have to set up an Inbound Rule for the Security Group of the Load Balancer.

Below is the setting I used. Use the setting below to solve this problem:

HTTPS       443     HTTP     80 <name of the certificate>

Welcome to Intellipaat Community. Get your technical queries answered by top developers !


Categories

...