0 votes
1 view
in DevOps and Agile by (29.3k points)

I am trying to install Docker CE on RHEL. This is my RHEL version:

Red Hat Enterprise Linux Server release 7.3 (Maipo)

When I execute this:

sudo yum -y install docker-ce

I am getting this error:

Error: Package: docker-ce-17.06.0.ce-1.el7.centos.x86_64 (docker-ce-stable)
           Requires: container-selinux >= 2.9
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
I tried using --skip-broken and rpm -Va --no files --no digest but again getting the same error. Please let me know how to resolve this issue and install Docker CE in RHEL 7.3.

1 Answer

0 votes
by (50.2k points)

There is a package that needs to be enabled. The package is container-seleniux package and this package is available from rhel-7-server-extras-rpms channel to resolve the error first enable this package using 

subscription-manager repos --enable=rhel-7-server-extras-rpms

The sources for this package have been exported to git.centos.org, so you could re-built it using mock.

If you don’t have a subscription to rhel 7 then you can use mock to build the package from the sources on git.centos.org. mock itself is in Extra Packages for Enterprise Linux, but it probably depends on some packages from Red Hat Enterprise Linux you have not installed yet, so you need to cross-grade to CentOS first.

If you wish to choose docker, then you can join Docker Training Course by Intellipaat.

Related questions

0 votes
1 answer
0 votes
1 answer
asked Apr 2, 2020 in AWS by chandra (29.3k points)
0 votes
1 answer
asked Jul 15, 2019 in AWS by yuvraj (19.2k points)
Welcome to Intellipaat Community. Get your technical queries answered by top developers !

Categories

...