0 votes
1 view
in Azure by (5.4k points)

I'm kicking the tires on the preview for the Visual Studio Team Services new Release Management system. My scenario is a classic website (ASP.NET 4.5) with a Git repo hosted in VSTS. The build definition is successful as seen here:

enter image description here

It is set up to publish as an artifact that can be picked up by Release Manager as shown here:

enter image description here

On the Release Manager side I have that artifact linked properly as shown here:

enter image description here

And here you can see my environments as well as the associated tasks (all 3 are clones)

enter image description here

When I run the release the build publishes fine, it connects to my subscription but when it attempts to find the package file it has the following error on line 101 of the output log:

"No files were found to deploy with the search pattern 'C:\a\4fe43dd1a***.zip'"

Here is the full output:

enter image description here

This is where I am stuck as I assumed my artifact link via VSTS should resolve this path for me. Obviously, I am missing an important piece of the puzzle somewhere, but I've followed the available documentation as best as I can.

If anyone has a solution or can point me in the right direction it would be much appreciated!

--- EDIT ---

I used the file picker to select a web deploy package (see below). I tried using the root website as well as the bin folder. Both attempts result in an error stating: "No files were found to deploy with search pattern 'C:\a\4fe43dd1a\Classic Website Definition\drop\ClassicWebsite\bin'"

enter image description here

--- EDIT 2 ---

I added an MSBuild task to my BUILD process with the following MSBuildArguments

/p:OutDir=$(build.stagingDirectory) /p:DeployOnBuild=true /p:WebPublishMethod=Package /p:PackageAsSingleFile=true /p:SkipInvalidConfigurations=true

and in my Copy/Publish Artifacts task I limited my output to only copy .zip files. Now in my RELEASE process when I navigate to find a "Web Deploy Package" the "drop" folder is empty. Here is a screenshot:

enter image description here

I think I'm on the right path, I just need help figuring out to tune my BUILD tasks to generate the right artifacts for my RELEASE process to use. Any help would be appreciated. 

1 Answer

0 votes
by (8.7k points)

Do the following: 

...