0 votes
1 view
in Python by (8.4k points)
edited by

I would like to install Python Pandas library (0.8.1) on Mac OS X 10.6.8. This library needs Numpy>=1.6.

I tried this:

$ sudo easy_install pandas

Searching for pandas

Reading http://pypi.python.org/simple/pandas/

Reading http://pandas.pydata.org

Reading http://pandas.sourceforge.net

Best match: pandas 0.8.1

Downloading http://pypi.python.org/packages/source/p/pandas/pandas-0.8.1.zip#md5=d2c5c5bea971cd760b0ae6f6850fcb74

Processing pandas-0.8.1.zip

Running pandas-0.8.1/setup.py -q bdist_egg --dist-dir /tmp/easy_install-ckAMym/pandas-0.8.1/egg-dist-tmp-0mlL7t

error: Setup script exited with pandas requires NumPy >= 1.6 due to datetime64 dependency

So I tried to install Numpy:

$ sudo easy_install numpy

Searching for numpy

Best match: numpy 1.6.2

Adding numpy 1.6.2 to easy-install.pth file

Using /Library/Python/2.6/site-packages

Processing dependencies for numpy

Finished processing dependencies for numpy

So, I tried again:

$ sudo easy_install pandas

But the problem is still the same !

error: Setup script exited with pandas requires NumPy >= 1.6 due to datetime64 dependency

I run Python

$ python

Python 2.6.1 (r261:67515, Jun 24 2010, 21:47:49) 

[GCC 4.2.1 (Apple Inc. build 5646)] on darwin

Type "help", "copyright", "credits" or "license" for more information.

>>> import numpy as np

>>> np.__version__

'1.2.1'

So Numpy 1.6 doesn't seem to be installed correctly!

I tried to install Numpy 1.6 with pip (instead of easy_install)...

$ sudo pip install numpy

Requirement already satisfied (use --upgrade to upgrade): numpy in /Library/Python/2.6/site-packages

Cleaning up...

I added --upgrade flag

$ sudo pip install numpy --upgrade

Requirement already up-to-date: numpy in /Library/Python/2.6/site-packages

Cleaning up...

$ sudo pip install pandas

Downloading/unpacking pandas

  Downloading pandas-0.8.1.zip (1.9MB): 1.9MB downloaded

  Running setup.py egg_info for package pandas

    pandas requires NumPy >= 1.6 due to datetime64 dependency

    Complete output from command python setup.py egg_info:

    pandas requires NumPy >= 1.6 due to datetime64 dependency

----------------------------------------

Command python setup.py egg_info failed with error code 1 in /tmp/pip-build/pandas

Storing complete log in /Users/MyUsername/Library/Logs/pip.log

I also tried to install a binary version of Numpy http://sourceforge.net/projects/numpy/files/ numpy-1.6.2-py2.6-python.org-macosx10.3.dmg but it fails !!! (installer said me that numpy 1.6.2 can't be installed on this disk. Numpy requires python.org Python 2.6 to install.

1 Answer

0 votes
by (16.8k points)

Use this command:

$python

>>import numpy

>>print(numpy)

Then simply go to  the location printed and delete the numpy installation. 

After all this, you can use pip or easy_install.

Welcome to Intellipaat Community. Get your technical queries answered by top developers !


Categories

...