Coming from a C# background the naming convention for variables and method names are usually either Camel Case or Pascal Case:
// C# example
string thisIsMyVariable = "a"
public void ThisIsMyMethod()
In Python, I have seen the above but I have also seen underscores being used:
# Python example
this_is_my_variable = 'a'
Is there a more preferable, definitive coding style for Python?