Back

Explore Courses Blog Tutorials Interview Questions
0 votes
1 view
in Java by (3.4k points)

I updated Eclipse with the new SDK tools (rev. 23), but now when Eclipse starts I receive the error: This Android SDK requires Android Developer Toolkit version 23.0.0 or above. Current version is 22.6.3.v201404151837-1123206. Please update ADT to the latest version. No updates were found with "Check for updates". If I try "Install new software", I can see version 23, but I can't upgrade due to the following error:

Cannot complete the install because of a conflicting dependency. Software being installed: Android Development Tools 23.0.0.1245622 (com.android.ide.eclipse.adt.feature.feature.group 23.0.0.1245622) Software currently installed: Android Developer Tools 22.2.1.v201309180102-833290 (com.android.ide.eclipse.adt.package.product 22.2.1.v201309180102-833290) Only one of the following can be installed at once: ADT Package 22.6.3.v201404151837-1123206 (com.android.ide.eclipse.adt.package 22.6.3.v201404151837-1123206) ADT Package 23.0.0.1245622 (com.android.ide.eclipse.adt.package 23.0.0.1245622) Cannot satisfy dependency: From: Android Development Tools 23.0.0.1245622 (com.android.ide.eclipse.adt.feature.feature.group 23.0.0.1245622) To: com.android.ide.eclipse.adt.package [23.0.0.1245622] Cannot satisfy dependency: From: Android Development Tools 22.6.3.v201404151837-1123206 (com.android.ide.eclipse.adt.feature.group 22.6.3.v201404151837-1123206) To: com.android.ide.eclipse.adt.package [22.6.3.v201404151837-1123206] Cannot satisfy dependency: From: ADT Package 22.2.1.v201309180102-833290 (com.android.ide.eclipse.adt.package.feature.group 22.2.1.v201309180102-833290) To: com.android.ide.eclipse.adt.feature.group 22.2.0 Cannot satisfy dependency: From: Android Developer Tools 22.2.1.v201309180102-833290 (com.android.ide.eclipse.adt.package.product 22.2.1.v201309180102-833290) To: com.android.ide.eclipse.adt.package.feature.group [22.2.1.v201309180102-833290]

After the download of the last ADT from the web site, it seems there's another problem. With SDK Tools rev. 23 proguard is not installed, the folder SDK dir/tools/proguard is missing, and other tools are missing. This version contains several bugs

1 Answer

0 votes
by (46k points)

Use Google's ADT v23.0.2. to solve the problems of previous versions:

Here's how to install it:

  • Tick ADT v23.0 for installation, then click "Next"

  • The eclipse will show "Install Remediation Page" because there is a conflict with the previous version. Select "Update my installation to be congenial with items being installed" to uninstall the old version and install the latest one. After that, proceed with the general steps.

Cheers…!!

Related questions

0 votes
1 answer
0 votes
1 answer
0 votes
1 answer
0 votes
1 answer
asked Oct 26, 2019 in Java by Anvi (10.2k points)

Browse Categories

...