Explore Courses Blog Tutorials Interview Questions
+1 vote
in DevOps and Agile by (29.3k points)

when I run my code I am getting below error message, Is anyone give me some insights for me Please. before it is worked and suddenly I am getting below error. 

Starting ChromeDriver 79.0.3945.36 (3582db32b33893869b8c1339e8f4d9ed1816f143-refs/branch-heads/3945@{#614}) on port 31613 Only local connections are allowed. Please protect ports used by ChromeDriver and related test frameworks to prevent access by malicious code. Exception in thread \\\"main\\\" org.openqa.selenium.WebDriverException: unknown error: Chrome failed to start: exited normally (unknown error: DevToolsActivePort file doesn\\\'t exist)

1 Answer

0 votes
by (50.2k points)

Reason: This can be occurred due to the update in the browser or your chromedriver might have expired. 

Solution: To resolve the issue check out your version of chrome and the chromedriver that you are using. If the chrome got updated then use the updated version of the driver.

For more details, check this selenium tutorial.

Browse Categories