Explore Courses Blog Tutorials Interview Questions
0 votes
in AWS by (12.9k points)

I have a problem with AWS Elastic Beanstalk. I tried to delete an environment. It started the process, but after a few minutes the environment "health bar" went to grey and gave me the following errors:

"Deleting security group named: XXXXX failed Reason: resource YYYYY has a dependent object"

"Stack deletion failed: The following resource(s) failed to delete: [AWSEBSecurityGroup]."

I tried to delete the security group from the error message, but I got this:

"XXXXXX: resource XXXXX has a dependent object"

After this I wanted to delete the dependence from the EB environment, but because it's Grey, it didn't allow me to do that.

I browsed the internet for hours, found a possible solution, where I need to do something at the EC2's Network Interfaces page, but it doesn't say any specific option or information.


1 Answer

+1 vote
by (18.2k points)
selected by
Best answer

The error message says that something outside of your environment is using the security group and that's why it can't be deleted. So, you'll have to identify the dependencies of the security group in other resources.

Related questions

Want to get 50% Hike on your Salary?

Learn how we helped 50,000+ professionals like you !

Browse Categories