0 votes
1 view
in AWS by (18.2k points)

I'm trying to deploy a rails 5.1 & react app created with webpacker gem using AWS Elastic Beanstalk. The problem is I keep getting the following error:

Webpacker requires Node.js >= 6.0.0 and you are using 4.6.0

I'm using Node 9.5.0 on my computer. Any suggestions??

1 Answer

0 votes
by (42.4k points)

To install nodejs using yum (assuming you're using the default Amazon Linux)

https://nodejs.org/en/download/package-manager/#enterprise-linux-and-fedora

curl --silent --location https://rpm.nodesource.com/setup_8.x | sudo bash -

yum -y install nodejs

Now to execute this on your instances, you need to add the required commands to a config file inside the .ebextensions dir, something like: .ebextensions/01_install_dependencies.config

File contents:

commands:

  01_download_nodejs:

    command: curl --silent --location https://rpm.nodesource.com/setup_8.x | sudo bash -

  02_install_nodejs:

    command: yum -y install nodejs

Welcome to Intellipaat Community. Get your technical queries answered by top developers !


Categories

...