0 votes
1 view
in AWS by (160 points)

I am trying to install yii2 on my Amazon Linux AMI instance, it requires the php-mbstring extension to work.

When I tried to run sudo yum install php-mbstring it returned this error:

Error: php56-common conflicts with php-common-5.3.29-1.8.amzn1.x86_64

Loaded plugins: priorities, update-motd, upgrade-helper

amzn-main/latest                                         | 2.1 kB     00:00

amzn-updates/latest                                      | 2.3 kB     00:00

2494 packages excluded due to repository priority protections

Resolving Dependencies

--> Running transaction check

---> Package php-mbstring.x86_64 0:5.3.29-1.8.amzn1 will be installed

--> Processing Dependency: php-common(x86-64) = 5.3.29-1.8.amzn1 for package: php-mbstring-5.3.29-1.8.amzn1.x86_64

--> Running transaction check

---> Package php-common.x86_64 0:5.3.29-1.8.amzn1 will be installed

--> Processing Conflict: php56-common-5.6.9-1.112.amzn1.x86_64 conflicts php-common < 5.5.22-1.98

--> Finished Dependency Resolution

Error: php56-common conflicts with php-common-5.3.29-1.8.amzn1.x86_64

You could try using --skip-broken to work around the problem

You could try running: rpm -Va --nofiles --nodigest

Thanks for your time in advance

Please log in or register to answer this question.

Welcome to Intellipaat Community. Get your technical queries answered by top developers !


Categories

...