0 votes
1 view
in Azure by (5.8k points)

I'm trying to install the qdap package in Azure ML. The rest of the dependent packages get installed without any issues. When it comes to qdapTools, I get this error, though the version that I try to install is 1.3.1 ( Verified this from the Description file that comes with the R package)

package 'qdapTools' 1.1.0 was found, but >= 1.3.1 is required by 'qdap

The code in "Execute R Script" :

install.packages("src/qdapTools.zip", repos = NULL, verbose = TRUE)

install.packages("src/magrittr.zip", lib = ".", repos = NULL, verbose = TRUE)

install.packages("src/stringi.zip", lib = ".", repos = NULL, verbose = TRUE)

install.packages("src/stringr.zip", lib = ".", repos = NULL, verbose = TRUE)

install.packages("src/qdapDictionaries.zip", lib = ".", repos = NULL, verbose = TRUE)

install.packages("src/qdapRegex.zip", lib = ".", repos = NULL, verbose = TRUE)

install.packages("src/RColorBrewer.zip", lib = ".", repos = NULL, verbose = TRUE)

install.packages("src/qdap.zip", lib = ".", repos = NULL, verbose = TRUE)

library(stringr, lib.loc=".", verbose=TRUE)

library(qdap, lib.loc=".", verbose=TRUE)

And the log :

[ModuleOutput] End R Execution: 9/22/2016 6:44:44 AM

[Stop]     DllModuleMethod::Execute. Duration = 00:00:16.7828106

[Critical]     Error: Error 0063: The following error occurred during evaluation of R script:

---------- Start of error message from R ----------

package 'qdapTools' 1.1.0 was found, but >= 1.3.1 is required by 'qdap'

package 'qdapTools' 1.1.0 was found, but >= 1.3.1 is required by 'qdap'

----------- End of error message from R -----------

[Critical]     {"InputParameters":{"DataTable":[{"Rows":2,"Columns":1,"estimatedSize":11767808,"ColumnTypes":{"System.String":1},"IsComplete":true,"Statistics":{"0":[2,0]}}],"Generic":{"bundlePath":"..\\..\\Script Bundle\\Script Bundle.zip","rLibVersion":"R310"},"Unknown":["Key: rStreamReader, ValueType : System.IO.StreamReader"]},"OutputParameters":[],"ModuleType":"LanguageWorker","ModuleVersion":" Version=6.0.0.0","AdditionalModuleInfo":"LanguageWorker, Version=6.0.0.0, Culture=neutral, PublicKeyToken=69c3241e6f0468ca;Microsoft.MetaAnalytics.LanguageWorker.LanguageWorkerClientRS;RunRSNR","Errors":"Microsoft.Analytics.Exceptions.ErrorMapping+ModuleException: Error 0063: The following error occurred during evaluation of R script:\r\n---------- Start of error message from R ----------\r\npackage 'qdapTools' 1.1.0 was found, but >= 1.3.1 is required by 'qdap'\r\n\r\n\r\npackage 'qdapTools' 1.1.0 was found, but >= 1.3.1 is required by 'qdap'\r\n----------- End of error message from R -----------\r\n   at Microsoft.MetaAnalytics.LanguageWorker.LanguageWorkerClientRS.ExecuteR(NewRWorker worker, DataTable dataset1, DataTable dataset2, IEnumerable`1 bundlePath, StreamReader rStreamReader, Nullable`1 seed) in d:\\_Bld\\8831\\7669\\Sources\\Product\\Source\\Modules\\LanguageWorker\\LanguageWorker.Dll\\EntryPoints\\RModule.cs:line 287\r\n   at Microsoft.MetaAnalytics.LanguageWorker.LanguageWorkerClientRS._RunImpl(NewRWorker worker, DataTable dataset1, DataTable dataset2, String bundlePath, StreamReader rStreamReader, Nullable`1 seed, ExecuteRScriptExternalResource source, String url, ExecuteRScriptGitHubRepositoryType githubRepoType, SecureString accountToken) in d:\\_Bld\\8831\\7669\\Sources\\Product\\Source\\Modules\\LanguageWorker\\LanguageWorker.Dll\\EntryPoints\\RModule.cs:line 207\r\n   at Microsoft.MetaAnalytics.LanguageWorker.LanguageWorkerClientRS.RunRSNR(DataTable dataset1, DataTable dataset2, String bundlePath, StreamReader rStreamReader, Nullable`1 seed, ExecuteRScriptRVersion rLibVersion) in d:\\_Bld\\8831\\7669\\Sources\\Product\\Source\\Modules\\LanguageWorker\\LanguageWorker.Dll\\EntryPoints\\REntryPoint.cs:line 105","Warnings":[],"Duration":"00:00:16.7752607"}

Module finished after a runtime of 00:00:17.1411124 with exit code -2

Module failed due to negative exit code of -2

Record Ends at UTC 09/22/2016 06:44:44.

Editing the code to :

install.packages("src/qdapTools.zip",lib="." , repos = NULL, verbose = TRUE)

install.packages("src/qdapDictionaries.zip", lib = ".", repos = NULL, verbose = TRUE)

install.packages("src/qdapRegex.zip", lib = ".", repos = NULL, verbose = TRUE)

install.packages("src/RColorBrewer.zip", lib = ".", repos = NULL, verbose = TRUE)

install.packages("src/qdap.zip", lib = ".", repos = NULL, verbose = TRUE)

library(qdapTools, lib.loc=".", verbose=TRUE)

library(qdap, lib.loc=".", verbose=TRUE)

throws the following error:-

[ModuleOutput] 4: package 'qdapTools' was built under R version 3.3.1 

[ModuleOutput] 

[ModuleOutput] End R Execution: 9/22/2016 7:11:05 AM

[Stop]     DllModuleMethod::Execute. Duration = 00:00:17.0656414

[Critical]     Error: Error 0063: The following error occurred during evaluation of R script:

---------- Start of error message from R ----------

package or namespace load failed for 'qdapTools'

package or namespace load failed for 'qdapTools'

----------- End of error message from R -----------

Not sure how to proceed, can someone help, please.

1 Answer

0 votes
by (9.5k points)

I hope this will help:

Welcome to Intellipaat Community. Get your technical queries answered by top developers !


Categories

...