Back

Explore Courses Blog Tutorials Interview Questions
0 votes
1 view
in AWS by (19.1k points)

I have successfully installed php70 and mysql. But when I am trying to install phpmyadmin by

$ sudo yum-config-manager --enable epel

And Then

$ sudo yum install -y phpMyAdmin

It gives me

--> Finished Dependency Resolution

Error: php70-common conflicts with php-common-5.3.29-1.8.amzn1.x86_64

Error: php56-common conflicts with php-common-5.3.29-1.8.amzn1.x86_64

You could try using --skip-broken to work around the problem

You could try running: rpm -Va --nofiles --nodigest

Also after google sometimes I found a solution that tries this

sudo yum install php70-mbstring

And I have tried this also, Still facing the same error.

Any suggestion...?

1 Answer

0 votes
by (44.3k points)

This worked when I removed PHP 7.0 and installed PHP 5.6. I do not know whether this is a better solution, but it worked.

For removing PHP 7.0:

sudo yum remove httpd24 php70 mysql56-server php70-mysqlnd

For installing PHP 5.6

sudo yum install httpd24 php56 mysql56-server php56-mysqlnd

Related questions

0 votes
1 answer

Want to get 50% Hike on your Salary?

Learn how we helped 50,000+ professionals like you !

0 votes
1 answer
asked Dec 19, 2020 in SQL by Appu (6.1k points)
0 votes
1 answer
0 votes
1 answer
Welcome to Intellipaat Community. Get your technical queries answered by top developers!

28.4k questions

29.7k answers

500 comments

94.2k users

Browse Categories

...