Intellipaat Back

Explore Courses Blog Tutorials Interview Questions
0 votes
in DevOps and Agile by (19.7k points)

I am trying to get selenium tests to run. Yet every time I try to run tests that should run IE I get an error on line 863 of htmlutils.js It says that I should disable my popup blocker. The thing is I went to IE tools-> turn of popup block.

So it is disabled and I get this error.

Is there something else I need to disable. I actually don't even know what version of internet explorer it is running since I am using Windows 7 Pro 64bit version. So when I do use IE I use the 64bit version but I am under the understanding if the site or something like that does not support 64bit it goes to 32bit.

So not sure what I need to do it to make it work.

This is the lines where it does

function openSeparateApplicationWindow(url, suppressMozillaWarning) {

    // resize the Selenium window itself

    window.resizeTo(1200, 500);

    window.moveTo(window.screenX, 0);

    var appWindow = + '?start=true', 'selenium_main_app_window');

    if (appWindow == null) {

        var errorMessage = "Couldn't open app window; is the pop-up blocker enabled?"


        throw new Error("Couldn't open app window; is the pop-up blocker enabled?");


Where is this log.error message stored? Maybe I can post that too.

1 Answer

0 votes
by (62.9k points)

I have had a similar problem on Vista and IE8 I would get the same error message as yours.

Couldn't open the app window; is the pop-up blocker enabled?"

Running my remote control as Admin wasn't an option for me, and also not being a good idea from the security perspective. So, in the end, I managed to solve this by changing the browser from "*ietha" to "*iexploreproxy" grid_configuration.yml


  port: 4444


    - name: "Internet Explorer 8 on Vista"

      browser: "*iexploreproxy"


Alternatively, you can change browser string from the code:

ISelenium selenium = new DefaultSelenium("localhost", 4444, "*iexploreproxy", "");

It works decently well.  

Browse Categories