+1 vote
1 view
in Python by (8.4k points)

I am trying to create a new plone environment using python plone-devstart.py tool. I got a bootstrap error. So, I used a command bin/python bootstrap.py -d from my project directory. It(bin/python bootstrap.py -d command) worked fine before But now i got an error like

[email protected]:~/demobrun$ bin/python bootstrap.py -d

Downloading http://pypi.python.org/packages/source/d/distribute/distribute-  

0.6.49.tar.gz

Extracting in /tmp/tmpDqVwYA

Now working in /tmp/tmpDqVwYA/distribute-0.6.49

Building a Distribute egg in /tmp/tmpv4Bzyv

/tmp/tmpv4Bzyv/distribute-0.6.49-py2.7.egg

Traceback (most recent call last):

File "bootstrap.py", line 118, in <module>

ws.require('zc.buildout' + VERSION)

File "build/bdist.linux-i686/egg/pkg_resources.py", line 698, in require

File "build/bdist.linux-i686/egg/pkg_resources.py", line 600, in resolve

pkg_resources.VersionConflict: (setuptools 0.6c11 (/home/oomsys/demobrun  

/lib/python2.7/site-packages/setuptools-0.6c11-py2.7.egg),    

Requirement.parse('setuptools>=0.7'))

1 Answer

0 votes
by (16.8k points)
edited by

Try this:

pip install --upgrade setuptools

as documented here https://askubuntu.com/questions/318824/how-to-solve-pkg-resources-versionconflict-error-during-bin-python-bootstrap-py/322701#322701

To know more about this you can have a look at the following video:-

Related questions

Welcome to Intellipaat Community. Get your technical queries answered by top developers !


Categories

...