0 votes
1 view
in DevOps and Agile by (19.8k points)

I am using Firefox 27 (previously 26) on Ubuntu 12.04 LTS with a Tomcat application with the Selenium stand alone server 2.39 (latest form Maven) including in the application. Everything works fine with Chrome but i would prefer to use Firefox, which cannot work. The Firefox is installed from the standard distributions using xvfb. Again, all the setup is fine as Chrome works, but when i try to use firefox with the following code:

WebDriver webDriver = new FirefoxDriver(); webDriver.get("www.google.com");

When i take a screen shot of the xvfb, i see a window with the following error: "Your firefox profile cannot be loaded. It may be missing or inaccessible".

The webDriver.get("www.google.com") just hangs and does not ever return.

The same code works fine on my development machine, Mac OSX.

I've tried to downgrade firefox and to no avail, same issue. Anyone have any suggestions?

1 Answer

0 votes
by (63.4k points)

This seems like an OS problem (read/write permissions or so), rather than a Selenium problem. It seems someone managed to fix it by changing the owner of the Firefox cache folder.

Try executing these commands:

sudo -s

chown -hR $USER:$USER ~/.cache/mozilla

Please take a look at this and let us know if it worked Ubuntu - Firefox profile cannot be loaded after upgrade

 

Welcome to Intellipaat Community. Get your technical queries answered by top developers !


Categories

...