Back

Explore Courses Blog Tutorials Interview Questions
0 votes
1 view
in SQL by (6.1k points)
edited by

I have been trying to connect my grails project to the Oracle database(Oracle 12c) in windows 8 operating system. 

However, whenever I am run my application I am getting the following exception :

Caused by: org.apache.commons.dbcp.SQLNestedException: 
Cannot create PoolableConnectionFactory (ORA-28040: 
No matching authentication protocol)

Caused by: 
java.sql.SQLException: ORA-28040: 
No matching authentication protocol

According to the internet suggestion, I also tried editing my *.ora file but still, it is not working.

I added the following snippet in sqlnet.ora file :

SQLNET.ALLOWED_LOGON_VERSION=10
SQLNET.ALLOWED_LOGON_VERSION_CLIENT=10
SQLNET.ALLOWED_LOGON_VERSION_SERVER=10

Here, I have tried assigning (10,11,12) but neither of them worked.

Can anyone please help me with this?

1 Answer

0 votes
by (12.7k points)

You can resolve this issue by using ojdbc8.jar instead of ojdbc14.jar.

Where Oracle 12c is compatible with ojdbc8.jar

If you want to learn more about SQL, Check out this SQL Certification by Intellipaat.

For more information visit :

Related questions

0 votes
1 answer
asked Jan 8, 2021 in SQL by Appu (6.1k points)
0 votes
1 answer
asked Jul 19, 2019 in SQL by Tech4ever (20.3k points)
0 votes
1 answer
asked Dec 6, 2020 in SQL by Appu (6.1k points)

Browse Categories

...