Back

Explore Courses Blog Tutorials Interview Questions
0 votes
2 views
in Java by (10.2k points)

I am trying to get my first taste of Android development using Eclipse. I ran into this problem when trying to run Eclipse, having installed version 4.2 only minutes ago.

After first trying to start Eclipse without any parameters to specify the Java VM, I got an error message saying it couldn't find a Java VM called javaw.exe inside the Eclipse folder, so I found where Java was installed and specified that location as the parameter in the shortcut's target. Now I get a different error, Java was started but returned exit code=13.

Similar questions seem to indicate that it's a 32-bit/64-bit conflict, but I'm 99% positive that I downloaded 64-bit versions of both Eclipse and Java (RE 7u5), which I chose because I have 64-bit Windows 7.

  • If anyone knows how to confirm that my Eclipse and Java are 64-bit, that'd be appreciated.

  • If you think my problem is a different one, please help!

  • Please speak as plainly as you can, as I am totally new to Eclipse and Java.

Shortcut Target: "C:\Program Files\Eclipse-SDK-4.2-win32-x86_64\eclipse\eclipse.exe" -vm "C:\Program Files (x86)\Java\jre7\bin\javaw.exe"

Full error code:-

Java was started but returned exit code=13 C:\Program Files (x86)\Java\jre7\bin\javaw.exe -Xms40m -Xmx512m -XX:MaxPermSize=256m -jar C:\Program Files\Eclipse-SDK-4.2-win32-x86_64\eclipse\\plugins/org.eclipse.equinox.launcher_1.30v20120522-1813.jar -os win32 -ws win32 -arch x86_64 -showsplash C:\Program Files\Eclipse-SDK-4.2-win32-x86_64\eclipse\\plugins\org.eclipse.platform_4.2.0.v201206081400\splash.bmp -launcher C:\Program Files\Eclipse-SDK-4.2-win32-x86_64\eclipse\eclipse.exe -name Eclipse --launcher.library C:\Program Files\Eclipse-SDK-4.2-win32-x86_64\eclipse\\plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.200.v201205221813\eclipse_1503.dll -startup C:\Program Files\Eclipse-SDK-4.2-win32-x86_64\eclipse\\plugins/org.eclipse.equinox.launcher_1.30v20120522-1813.jar --launcher.overrideVmargs -exitdata 1e30_5c -vm C:\Program Files (x86)\Java\jre7\bin\javaw.exe -vmargs -Xms40m -Xmx512m -XX:MaxPermSize=256m -jar C:\Program Files\Eclipse-SDK-4.2-win32-x86_64\eclipse\\plugins/org.eclipse.equinox.launcher_1.30v20120522-1813.jar

1 Answer

0 votes
by (46k points)

Here are some methods to solve this error:

 

Method 1:

 

You may get this error if the versions of java and eclipse don't match. If you have installed 64-bit java JDK on your computer and 32-bit Eclipse IDE or vice versa, then you may get this error.

 

So, assure that you have installed both the software with their correct versions. If you installed different versions, you will have to uninstall the software and install them again with the corresponding version.

 

Method 2:

 

There are situations when you want to keep both the 32-bit version and 64-bit version installed in your computer due to compatibility issues.

 

When this is the situation, you need to precisely mention the path of the system variables in the Environment Variable Settings. You have to choose either 32 bit or 64 bit in both the software i.e., Eclipse and Java JDK.

 

Assume you select 32-bit versions, you need to go to the C drive in the JDK Folder of the 32-bit version. Once you do that, you can mimic the path and set it in the Environment Variable section. You won’t get the same error again.

 

Method 3:

 

Another resolution to this error is by copying the Eclipse folder in the C:/Program Files folder. For some, this may work. However, if it doesn't work, you should try fixing the Eclipse Folder in the C:/Program Files (x86) folder.

 

We believe that at least one of the above methods will work in your system. You may have to try all three ways. One of them will solve your error report “Java was started but returned exit code 13”.

Welcome to Intellipaat Community. Get your technical queries answered by top developers!

28.4k questions

29.7k answers

500 comments

94.1k users

Browse Categories

...