0 votes
1 view
in RPA by (12.8k points)

I am trying to connect oracle 12 c DB using my automation anywhere client. However, I get the below error. Unable to initialize provider, Oracle client and networking components not found.

what is tried: I understand its because of missing ODAC components and I did download and install them but I am clueless what to do next as it is still giving the same error. Is there some configuration required?

At the end of ODAC installation, there were instructions to run some SQL files as below 

InstallOracleASPNETCommon.sql

InstallOracleMembership.sql

InstallOraclePersonalization.sql

InstallOracleProfile.sql

InstallOracleRoles.sql

InstallOracleSiteMap.sql

InstallOracleWebEvents.sql

InstallOracleSessionState.sql

I ran them all however not sure they even relate to my issue. I still get the error. My AA client and ODAC and Oracle 12c all are in 64 bit and so is my machine. I have verified the username , password and the service name(tns) and they are good. it is the odac issue and I am unable to resolve it.

1 Answer

0 votes
by (29.8k points)

Hi, here is what you can try

1) install SQL developer or any other supporting oracle IDE tool in your machine and check if you are able to connect to the database. check if correct tns is used. if you are getting correct results in oracle tools which will confirm that your oracle is working fine in your machine( all drivers are present).

2) Create a new ODBC connection in your machine. test if the connection is successful or not

Try to run again it should work

Welcome to Intellipaat Community. Get your technical queries answered by top developers !


Categories

...