+1 vote
1 view
in DevOps and Agile by (30k points)

I'm new to Puppet but picking it up quickly. Today, I'm running into an issue when trying to run the following:

$ puppet agent --no-daemonize --verbose --onetime

**err: Could not request certificate: getaddrinfo: Name or service not known

Exiting; failed to retrieve certificate and waitforcert is disabled**

It would appear the agent doesn't know what server to connect to. I could just specify --server on the command line, but that will be of no use to me when this runs as a daemon in production, so instead, I specify the server name in /etc/puppet/puppet.conf like so:

[main]

    server = puppet.<my domain>

I do have a DNS entry for puppet.<my domain> and if I dig puppet.<my domain>, I see that the name resolves correctly.

All puppet documentation I have read states that the agent tries to connect to a puppet master at puppet by default and your options are host file trickery or do the right thing, create a CNAME in DNS, and edit the puppet.conf accordingly, which I have done.

So what am I missing? Any help is greatly appreciated!

1 Answer

0 votes
by (51.2k points)

For this issue, run the command with sudo then it will work fine.

Welcome to Intellipaat Community. Get your technical queries answered by top developers !

Categories

...