0 votes
1 view
in DevOps and Agile by (30k points)

First i have tried the below approach which doesn't work for me

First try:
Reference only followed for puppet agent: https://puppet.com/docs/puppet/3.8/install_el.html
sudo su
vi /etc/hosts
#Add IP and Alias in /etc/hosts
ping puppet
sudo rpm -ivh https://yum.puppetlabs.com/puppetlabs-release-el-7.noarch.rpm
yum install puppet -y (The reason i didn't used puppet-agent here because it was not able to find the package)
systemctl enable puppet
systemctl start puppet
But there is no luck but when i tried '-uvh' by watching intellipaat tutorial then it installed properly. Can any one tell me the difference between '-ivh' and '-uvh'.

1 Answer

0 votes
by (51.2k points)

Reason: When you tried to use '-ivh' due to some reasons complete package is not installed properly.

Difference: Where -ivh will install the package but if there is any pre-installed or the package is not installed properly then you will face the issue.

But when we use '-uvh' then first this will uninstall the previous version and install the new version. So if there is any broken file then that will be removed and install again.

For more information check this puppet tutorial.

Related questions

+1 vote
1 answer
asked Mar 7, 2020 in DevOps and Agile by chandra (30k points)
+1 vote
1 answer
asked Aug 17, 2019 in DevOps and Agile by chandra (30k points)
0 votes
1 answer
Welcome to Intellipaat Community. Get your technical queries answered by top developers !

Categories

...