0 votes
1 view
in AWS by (8.9k points)

I've created a new linux instance on Amazon EC2, and as part of that downloaded the .pem file to allow me to SSH in.

When I tried to ssh with:

ssh -i myfile.pem <public dns>

I got:

@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@

@     WARNING: UNPROTECTED PRIVATE KEY FILE!          @

@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@

Permissions 0644 for 'amazonec2.pem' are too open.

It is recommended that your private key files are NOT accessible by others.

This private key will be ignored.

bad permissions: ignore key: amazonec2.pem

Permission denied (publickey).

Following this post I tried to chmod +600 the pem file, but now when I ssh I just get:

Permission denied (publickey).

What school-boy error am I making here? The .pem file is in my home folder (in osx). It's permissions look like this:

[email protected]   1 mattroberts  staff    1696 19 Nov 11:20 amazonec2.pem

1 Answer

0 votes
by (18.5k points)

Your key pair file should not be publicly viewable for SSH to work. The key pair file should be in read only mode and available for the owner only. 

You can run the following command to resolve this issue:

chmod 400 mykey.pem

Welcome to Intellipaat Community. Get your technical queries answered by top developers !


Categories

...