Back

Explore Courses Blog Tutorials Interview Questions
0 votes
1 view
in Azure by (5.8k points)

I just upgraded my SSMS to 2008 R2. I'm missing the option to select the top 1000 rows from a table, like this:

enter image description here

Mine looks like this:

enter image description here

I know how to change the number of rows that are displayed, but the options aren't there at all. I saw that someone submitted a bug for this a few years ago, but there was no workaround, and I'm not sure what to do. Any ideas?

EDIT - Azure Problem?

I just used SSMS to open my local SQL Server, and I get the option to select the top 100 rows. But in my other SSMS instance, the one that is connected to my Azure DB, I don't see it. Is it possibly an Azure limitation?

1 Answer

0 votes
by (9.6k points)

You can try this command from your SSMS:

select top 100 * from SalesLT.Customer

My SSMS is linked to AzureDB.  So there is no Azure limitation as such.

Welcome to Intellipaat Community. Get your technical queries answered by top developers!

28.4k questions

29.7k answers

500 comments

94.2k users

Browse Categories

...