Back

Explore Courses Blog Tutorials Interview Questions
0 votes
1 view
in Linux by (18.4k points)
edited by

When am trying to reboot my server I get an error message:

Kernel panic - not syncing - Attempted to kill init!

and it just hangs.

Is there a solution to this problem? This server is used by ten people so I don't want to reinstall deleting their data.

1 Answer

0 votes
by (36.8k points)

If your full message is:

kernel panic - not syncing: Attempted to kill inint !

PId: 1, comm: init not tainted 2.6.32.-279-5.2.e16.x86_64 #1

then you have to disabled selinux and after that, you have rebooted your system.

The easiest way is by using a live OS and re-enable it

vim /etc/selinux/config

    ...

    SELINUX=enforcing

    ...

The 2nd choice is to disable the selinux in a kernel argument by adding selinux=0

vim /boot/grub/grub.conf

    ...

    kernel /boot/vmlinuz-2.4.20-selinux-2003040709 ro root=/dev/hda1 nousb selinux=0

    ...

source kernel panic - not syncing: Attempted to kill inint !

To know about Linux join the Linux training

 

Related questions

0 votes
1 answer
0 votes
1 answer
0 votes
1 answer

Browse Categories

...