0 votes
1 view
in RPA by (11.8k points)

I've tried nearly anything, The "Type Into" activity won't print plain text into the text box let alone a held variable. The textbox element in question is the update work items comment box in the acme-test website from the Level 3 RPA developer course. I am able to type into the box manually and the robot is able to find it (the cursor moves to the center of the text box and the program continues). I've tried quite a lot, including using a click activity and then sending the string as hotkeys.

1 Answer

0 votes
by (27.7k points)

I think that the error is related to your selectors. Since you are on level 3 RPA developer course I assume you are using Reframework for the task and I believe because of the exceptional error handling capabilities of this template your application just moves on with the next item instead of crashing when it can't find the element.

To solve the selector issue you can try the following:

  1. Use partial selectors instead of full selectors
  2. Use wildcards for dynamic parts of your selectors (* for replacing any number of characters, ? for replacing exactly 1 character)

you need to remember the fact if you have used basic recorder functionality of UI path it generates full selectors.

Related questions

+1 vote
1 answer
asked Jul 2 in RPA by Abhishek_31 (11.8k points)
0 votes
1 answer
+1 vote
1 answer
Welcome to Intellipaat Community. Get your technical queries answered by top developers !


Categories

...