0 votes
1 view
in AWS by (19.2k points)

Since this evening I can't connect to my AWS EC2 instances. It keeps telling me the following:

dlopen private.pem failed: dlopen(private.pem, 2): no suitable image found.  Did find: private.pem: file too short

This is the output of my ssh connection:

'''ssh $SSHOPTS -I private.pem [email protected]

OpenSSH_6.2p2, OSSLShim 0.9.8r 8 Dec 2011

debug1: Reading configuration data /Users/evertvancauwenberg/.ssh/config

debug1: Reading configuration data /etc/ssh_config

debug1: /etc/ssh_config line 20: Applying options for *

debug1: /etc/ssh_config line 53: Applying options for *

debug1: Connecting to 54.213.238.233 [54.213.238.233] port 22.

debug1: Connection established.enter code here

dlopen private.pem failed: dlopen(private.pem, 2): no suitable image found.  Did find:

    private.pem: file too short

debug1: identity file /Users/evertvancauwenberg/.ssh/id_rsa type 1

debug1: identity file /Users/evertvancauwenberg/.ssh/id_rsa-cert type -1

debug1: identity file /Users/evertvancauwenberg/.ssh/id_dsa type -1

debug1: identity file /Users/evertvancauwenberg/.ssh/id_dsa-cert type -1

debug1: Enabling compatibility mode for protocol 2.0

debug1: Local version string SSH-2.0-OpenSSH_6.2

debug1: Remote protocol version 2.0, remote software version OpenSSH_6.0p1 Debian-4

debug1: match: OpenSSH_6.0p1 Debian-4 pat OpenSSH*

debug1: SSH2_MSG_KEXINIT sent

debug1: SSH2_MSG_KEXINIT received

debug1: kex: server->client aes128-ctr hmac-md5 none

debug1: kex: client->server aes128-ctr hmac-md5 none

debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent

debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP

debug1: SSH2_MSG_KEX_DH_GEX_INIT sent

debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY

debug1: Server host key: RSA 6f:80:22:e6:cd:c0:84:c4:1c:11:a8:bb:ee:55:2e:75

The authenticity of host '54.213.238.233 (54.213.238.233)' can't be established.

RSA key fingerprint is 6f:80:22:e6:cd:c0:84:c4:1c:11:a8:bb:ee:55:2e:75.

Are you sure you want to continue connecting (yes/no)? yes

Warning: Permanently added '54.213.238.233' (RSA) to the list of known hosts.

debug1: ssh_rsa_verify: signature correct

debug1: SSH2_MSG_NEWKEYS sent

debug1: expecting SSH2_MSG_NEWKEYS

debug1: SSH2_MSG_NEWKEYS received

debug1: Roaming not allowed by server

debug1: SSH2_MSG_SERVICE_REQUEST sent

debug1: SSH2_MSG_SERVICE_ACCEPT received

debug1: Authentications that can continue: publickey

debug1: Next authentication method: publickey

debug1: Offering RSA public key: /Users/evertvancauwenberg/.ssh/id_rsa

debug1: Authentications that can continue: publickey

debug1: Trying private key: /Users/evertvancauwenberg/.ssh/id_dsa

debug1: No more authentication methods to try.

Permission denied (publickey).

I'm working on OSX 10.9.2 with ssh -v

OpenSSH_6.2p2, OSSLShim 0.9.8r 8 Dec 2011

usage: ssh [-1246AaCfgKkMNnqsTtVvXxYy] [-b bind_address] [-c cipher_spec]

           [-D [bind_address:]port] [-e escape_char] [-F configfile]

           [-I pkcs11] [-i identity_file]

           [-L [bind_address:]port:host:hostport]

           [-l login_name] [-m mac_spec] [-O ctl_cmd] [-o option] [-p port]

           [-R [bind_address:]port:host:hostport] [-S ctl_path]

           [-W host:port] [-w local_tun[:remote_tun]]

           [[email protected]]hostname [command]

1 Answer

0 votes
by (44.6k points)

You just need to use -i (identity file) option instead of using -I:

ssh -i keyfile.pem [email protected]

Welcome to Intellipaat Community. Get your technical queries answered by top developers !


Categories

...