0 votes
1 view
by (8.4k points)

I have setup Sever, database and Firewall Setting (Rule) In windows Azure. I Have added The IP In firewall setting which is populating under the Windows Azure Firewall Tab.

When I am trying connect with Database using Manage from Azure Platform I am getting this error message.

Firewall check failed. Cannot open server 'XXXXXXXXX' requested by the login. Client with IP address 'XXXXXXXXX' is not allowed to access the server. To enable access, use the SQL Azure Portal or run sp_set_firewall_rule on the master database to create a firewall rule for this IP address or address range. It may take up to five minutes for this change to take effect.

And I am also Not able to connect via Sql Server Management Studio. Getting Same connection issue Error for My IP Address.

I am not using static IP but my IP haven't change during this process. I have tried lot Example but all are saying To add firewall rule That I had already done.

I have Added Firewall exception for port Number 1433.

But still this is not working Please let me know that what type of setting is still missing.

Thanks in advance.

1 Answer

0 votes
by (16.8k points)

In order to manage SQL Azure from the Azure Portal you have to check the "Allow other Windows Azure Services to connect to this server". That is also required later for your Web/Worker roles deployed to Azure: enter image description here

If you want to connect from your home/work PC, you have to keep the firewall up-to-date with your public IP address! Your public IP Address is in the little popup windows, which pops out when you want to add new firewall rule:

enter image description here

Welcome to Intellipaat Community. Get your technical queries answered by top developers !


Categories

...