0 votes
1 view
in Devops and Agile by (22.3k points)

I am unable to clone HTTPS repositories. I can clone SSH repos fine, but not HTTPS repos. I cannot test the GIT protocol since I am behind a corporate firewall.

This is what I am trying to do:

$ git clone https://github.com/nvie/gitflow.git

Cloning into gitflow...

fatal: Unable to find remote helper for 'https'

I have so far tried the following (based on Google searches)

Purging and installing Git through apt-get

Installing build-deps for Git through apt-get

Installing curl dev libraries

Installing expat libraries

Downloading Git source and building using:

./configure --prefix=/usr --with-curl --with-expat

Also tried pointing configure at curl binary (./configure --prefix=/usr --with-curl=/usr/bin/curl)

I have tried everything I can find on the internet with no luck. Can anyone help me?

Git version = 1.7.6.4

OS = Ubuntu 11.04

1 Answer

0 votes
by (38.3k points)

In this case, the error occurs due to missing of libraries to resolve this use the following commands:

For centOS:

yum install curl-devel

 #  move the file to wherever the source for git is

cd /usr/local/src/git-1.7.9  

 ./configure

 make

 make install

On Ubuntu you could use:

sudo apt-get install libcurl4-openssl-dev 

...