0 votes
1 view
in AWS by (12.2k points)

I have followed the steps for resizing an EC2 volume

1. Stopped the instance

2. Took a snapshot of the current volume

3. Created a new volume out of the previous snapshot with a bigger size in the same region

4. Deattached the old volume from the instance

5. Attached the new volume to the instance at the same mount point

Old volume was 5GB and the one I created is 100GB Now, when i restart the instance and run df -h I still see this

Filesystem            Size  Used Avail Use% Mounted on

/dev/xvde1            4.7G  3.5G 1021M  78% /

tmpfs                 296M     0  296M   0% /dev/shm

This is what I get when running

sudo resize2fs /dev/xvde1

The filesystem is already 1247037 blocks long.  Nothing to do!

If I run cat /proc/partitions I see

 202       64  104857600 xvde

 202       65    4988151 xvde1

 202       66     249007 xvde2

From what I understand if I have followed the right steps xvde should have the same data as xvde1 but I don't know how to use it

How can I use the new volume or umount xvde1 and mount xvde instead?

I cannot understand what I am doing wrong

I also tried sudo ifs_growfs /dev/xvde1

xfs_growfs: /dev/xvde1 is not a mounted XFS filesystem

Btw, this a linux box with centos 6.2 x86_64

Thanks in advance for your help

1 Answer

0 votes
by (18.6k points)

To unmount xvde1, use the following command:

[ec2-user ~]$ umount -d /dev/xvde1

After unmounting xvde1, your mount point will be available to use. So, to mount xvde on that same mount point use the following command:

[ec2-user ~]$ sudo mount /dev/xvde /data

Here 'data' is the mount point.

Related questions

Welcome to Intellipaat Community. Get your technical queries answered by top developers !


Categories

...